Search
 
 

Display results as :
 


Rechercher Advanced Search

Top posters
agoenk (2095)
 
viyan_cs (1036)
 
b-joe (749)
 
ieyaz_Chuit (725)
 
Zell Aristocrats (667)
 
jun43d1 (638)
 
Hetro_fabio (314)
 
twinkblack (265)
 
suzee_tkj2 (237)
 
harmoko (184)
 

December 2016
MonTueWedThuFriSatSun
   1234
567891011
12131415161718
19202122232425
262728293031 

Calendar Calendar

Affiliates
tkjpower.multiply.com
 

Cara mengatasi wifi wireless lan card yang tidak bisa terdeteksi di linux

View previous topic View next topic Go down

Cara mengatasi wifi wireless lan card yang tidak bisa terdeteksi di linux

Post by agoenk on Sat Feb 20, 2016 6:50 pm

ketika kita menginstal linux misalkan linux mint, terkadang wireless card kita tidak terdeteksi. dibawah ini adalah salah satu cara agar wireless card kita bisa terdeteksi di linux mint

pertama kita perlu mengetahui jenis wlan kita dengan cara masuk terminal kemudian masuk super user dan ketikan lspci,

jenis wlan Broadcom Corporation BCM43142 caranya adalah :

I just installed LMDE 201403, and as expected, I had problems with my wireless. I had installed debian (stable) in the same computer, a Lenovo Edge E431, and the wireless didn't work, but I managed to fix the problem following this blog:
http://thedubiousdisc.wordpress.com/201 ... on-debian/
So, I followed the same steps after installing LMDE, but now it didn't work. Now I show you what I did:
First of all, lspci

Code: Select all
   # lspci | grep Network
   04:00.0 Network controller: Broadcom Corporation BCM43142 802.11b/g/n (rev 01)



following the instructions of the blog, I ran

Code: Select all
   apt-get install linux-headers-generic build-essential dkms broadcom-sta-modules



In debian stable I had no error, but now the linux-headers-generic package is missing:

Code: Select all
   Package linux-headers-generic is not available, but is referred to by another package.
   This may mean that the package is missing, has been obsoleted, or
   is only available from another source

   E: Package 'linux-headers-generic' has no installation candidate



I skipped that part and installed the other packages:

Code: Select all
   #apt-get install build-essential dkms broadcom-sta-modules
   Reading package lists... Done
   Building dependency tree      
   Reading state information... Done
   Note, selecting 'broadcom-sta-dkms' instead of 'broadcom-sta-modules'
   build-essential is already the newest version.
   dkms is already the newest version.
   The following NEW packages will be installed:
     broadcom-sta-dkms
   0 upgraded, 1 newly installed, 0 to remove and 18 not upgraded.
   Need to get 1,745 kB of archives.
   After this operation, 9,965 kB of additional disk space will be used.
   Do you want to continue? [Y/n] y
   Get:1 http://debian.linuxmint.com/latest/ testing/non-free broadcom-sta-dkms all 6.30.223.141-1 [1,745 kB]
   Fetched 1,745 kB in 5s (346 kB/s)            
   Selecting previously unselected package broadcom-sta-dkms.
   (Reading database ... 146477 files and directories currently installed.)
   Unpacking broadcom-sta-dkms (from .../broadcom-sta-dkms_6.30.223.141-1_all.deb) ...
   Setting up broadcom-sta-dkms (6.30.223.141-1) ...
   Loading new broadcom-sta-6.30.223.141 DKMS files...
   First Installation: checking all kernels...
   Building only for 3.11-2-amd64
   Building initial module for 3.11-2-amd64
   Done.

   wl:
   Running module version sanity check.
   - Original module
      - No original module exists within this kernel
   - Installation
      - Installing to /lib/modules/3.11-2-amd64/updates/dkms/

   depmod.....

   Backing up initrd.img-3.11-2-amd64 to /boot/initrd.img-3.11-2-amd64.old-dkms
   Making new initrd.img-3.11-2-amd64
   (If next boot fails, revert to initrd.img-3.11-2-amd64.old-dkms image)
   update-initramfs....

   DKMS: install completed.
   Processing triggers for initramfs-tools ...
   update-initramfs: Generating /boot/initrd.img-3.11-2-amd64



Finally I installed the .deb:

Code: Select all
   # dpkg -i wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb
   (Reading database ... 146537 files and directories currently installed.)
   Preparing to replace wireless-bcm43142-dkms 6.20.55.19-1 (using wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb) ...

   ------------------------------
   Deleting module version: 6.20.55.19
   completely from the DKMS tree.
   ------------------------------
   Done.
   Unpacking replacement wireless-bcm43142-dkms ...
   Setting up wireless-bcm43142-dkms (6.20.55.19-1) ...
   Loading new wireless-bcm43142-6.20.55.19 DKMS files...
   Building only for 3.11-2-amd64
   Building initial module for 3.11-2-amd64
   Error! Bad return status for module build on kernel: 3.11-2-amd64 (x86_64)
   Consult /var/lib/dkms/wireless-bcm43142/6.20.55.19/build/make.log for more information.



Even having an error i kept going, so i ran the modprobe wl, but it didn't do anything. I searched ways to fix the "Bad return status for module build on kernel: 3.11-2-amd64 (x86_64)" error, but I couldn't find anything. I also tried to solve the linux headers error, but I don't know which headers should be installed to fix this. There's another solution to my problem in thinkwiki:
http://www.thinkwiki.org/wiki/Installin ... _Edge_E135
but it implies using an ubuntu package, and i'm not sure of using this.

If anyone is asking about the make.log, here it is:

Code: Select all
   DKMS make.log for wireless-bcm43142-6.20.55.19 for kernel 3.11-2-amd64 (x86_64)
   Fri Apr 11 11:47:41 CLST 2014
   make: Entering directory `/usr/src/linux-headers-3.11-2-amd64'
   CFG80211 API is prefered for this kernel version
   Using CFG80211 API
     LD      /var/lib/dkms/wireless-bcm43142/6.20.55.19/build/built-in.o
     CC [M]  /var/lib/dkms/wireless-bcm43142/6.20.55.19/build/src/shared/linux_osl.o
     CC [M]  /var/lib/dkms/wireless-bcm43142/6.20.55.19/build/src/wl/sys/wl_linux.o
   /var/lib/dkms/wireless-bcm43142/6.20.55.19/build/src/wl/sys/wl_linux.c: In function ‘wl_tkip_printstats’:
   /var/lib/dkms/wireless-bcm43142/6.20.55.19/build/src/wl/sys/wl_linux.c:2696:7: warning: passing argument 1 of ‘wl->tkipmodops->print_stats’ from incompatible pointer type [enabled by default]
          wl->tkip_bcast_data[idx]);
          ^


atau bisa secara lebi lengkap dilihat di

http://forums.linuxmint.com/viewtopic.php?f=191&t=164676


untuk wifi RTL8723BE


Buka terminal linux mint.
Masuk ke SU dan ketikkan “lspci“. “lspci” berguna untuk melihat tipe perangkat-perangkat yang terkoneksi pada soket PCI komputer.
lihat tipe wireless network adapter nya, apabila perangkat memiliki wifi adapter tipe RTL8723BE apabila tipe sesuai silahkan anda ikuti langkah selanjutnya. jika tidak maka cerita anda sampai disini.
kemudian ketikkan “sudo apt-get install linux-headers-generic build-essential git” pada terminal, kode tersebut berfungsi untuk menambahkan header repository github directory pada linux mint yang terinstall.
download driver dari github directory dengan cara mengetikkan kode berikut “git clone http://github.com/lwfinger/rtl8723be” pelalui terminal.
pindah ke directory dimana driver di download dengan mengetikkan “cd rtl8723be” pada terminal.
Tahap ke tujuh ini yang sempat buat penulis puyeng, driver tidak dapat di install dengan error bahwa driver sudah tidak cocok lagi dengan os yang teristall. maka yang penulis lakukan adalah dengan cara merubah directory dengan data yang lebih lawas dengan cara mengetikkan “git checkout 604aa9058fb9e5bb1cf571c99989d081f8fc8b9” pada terminal.
tahap terakhir adalah melakukan penginstallan dengan cara mengetikkan kode “make“,”sudo make” dan “sudo modprobe rtl8723be” secara berurutan di terminal.
Driver wifi RTL8723BE telah terinstall dan siap digunakan

sumber :

https://kurnivan.wordpress.com/2014/10/22/memperbaiki-wifi-tidak-terdeteksi-linux-mint-17-qiana-lenovo-dan-gigabite-brix-minipc/


agoenk
tkjholic
tkjholic

Posts : 2095
Join date : 2009-03-11

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum